Back to overview
Degraded
Model Data Delays
May 29 at 06:10pm UTC
Affected services
GREarth
RadarScope
Weather Data Overlays
Resolved
May 29 at 08:05pm UTC
Model dataflow has resumed. 2 hour delays expected.
Affected services
GREarth
RadarScope
Weather Data Overlays
Created
May 29 at 06:10pm UTC
Model data is delayed as of 1810Z due to supercomputer problems at the NWS.
Affected services
GREarth
RadarScope
Weather Data Overlays