Back to overview
Degraded
SPC Watches
Mar 24 at 01:06am UTC
Affected services
Weather Data Overlays
Resolved
Mar 25 at 05:09pm UTC
We believe we have resolved the problem with the watch outline data feeds.
Affected services
Weather Data Overlays
Created
Mar 24 at 01:06am UTC
We're aware of an issue with SPC Watches not displaying. We're actively working to resolve this issue which is directly related to upgrades.
Affected services
Weather Data Overlays